Welcome! To use this support forum, please Login or Join Today!

   

Menus commented out and don’t display

{name}
Rank

Total Posts: 10

Joined 2011-07-31

PM

 

Hi Casey—
correspondance to/from our web guy:

TO:
no menus are showing.  I get breadcrumbs, but no menus (neither top nor the one under the banner.)  I’ve deleted and recreated menus.  Even with menus off, parent pages don’t show up as menus.

You’ll see I have a menu named “site menu” that I’m expecting to see below the logo.  If I preview other themes, the menu appears.

FROM:

The menus are there in the code, they are just commented out when they are included, so they never get displayed. It might be st_header, it might be something else. I think this is another ask the developer as it is crazy odd that these are not showing up.

If you look at the code:

<div id="topmenu" class="grid_16">
<!-- <
div class="menu-site-menu-container"><ul id="menu-site-menu" class="menu"><li id="menu-item-42" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42"><a href="http://scstemhub-test.drake.edu/">Home</a></li>
<
li id="menu-item-41" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41"><a href="http://scstemhub-test.drake.edu/advisory-board/">Advisory Board</a></li>
</
ul></div> -->
</
div>

<!-- 
BEGIN HEADER -->
<
div id="header" class="container_24 clearfix">
<
span id="graphic"><a  href="http://scstemhub-test.drake.edu/" title="South Central Iowas Science, Technology, Engineering &amp; Mathematics Hub">SC STEM Hub</a></span>
<!--<
div id="menu_wrap" class="below" ><div id "menu"><div class="menu-site-menu-container"><ul id="menu-site-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42"><a href="http://scstemhub-test.drake.edu/">Home</a></li>
<
li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41"><a href="http://scstemhub-test.drake.edu/advisory-board/">Advisory Board</a></li>
</
ul></div></div></div> --> 

—————————————-

You can see that the menu is there in both cases, it is just wrapped in comments so it doesn’t appear. Hope this gives you enough info to quickly hear back from the dev and get it resolved.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

Hi, would it be possible to PM me with your wp-admin info. It looks like a basic misconfiguration in WordPress.