Welcome! To use this support forum, please Login or Join Today!

   

slideshow stopped working

{name}
Rank

Total Posts: 4

Joined 2012-03-13

PM

 

The slideshow has worked fine for 2 days and then all of a sudden I discovered it’s not working. The pagination does not show. I tried prenext and it doesn’t show either. It just stays on the first image. I don’t know what to do! Any suggestions?Here is the code from that section:

[raw] [slideshow effect=“crossfade” category=“12” width=“605” height=“250” autoplay=“4000” speed=“1000” paginati prevnext=“false”] [/raw]

Link to page in development: http://drtimbrooks.com/wordpress/

Also noticed that a Slideshow tab is not located on the Onyx Options.

{name}
Rank

Total Posts: 23

Joined 2012-02-01

PM

 

Hi,
The slideshows have also stopped working on my site.
Maybe the theme is loading a new JavaScript file version now or something like that.

Anyway… if you could have a look, I would really appreciate it.

Thanks,
Kirk.

{name}
Rank

Total Posts: 4

Joined 2012-03-13

PM

 

OMG - at least I am not alone.  I can’t find anything wrong on my end, except that it just stopped working.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

Hi all, This looks like an issue with the latest version of jQuery.

To fix this, you’ll need to FTP into your wp-content/themes/onyx/lib/functions folder and open header_functions.php.

Around line #20 you’ll see this code:

  if (!is_admin()) {
    wp_deregister_script('jquery');
    if (is_ssl()) {
      wp_register_script('jquery', 'https://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js');
      } else {    
      wp_register_script('jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js');
      }
    wp_enqueue_script('jquery');
  }

We no longer want to use the latest version of jQuery, instead depend on the core WordPress version. Replace the above with simply this:

  if (!is_admin()) {
    wp_enqueue_script('jquery');
  }

I’ve updated the repository with this as well. My apologies for any issues this may have caused.

 

{name}
Rank

Total Posts: 23

Joined 2012-02-01

PM

 

Hi Casey,

Yep… that fixes the slideshow issue.

Thank you very much.
Kirk.

{name}
Rank

Total Posts: 4

Joined 2012-03-13

PM

 

Thanks for your help!  Also, it fixed the lightbox problem.