Welcome! To use this support forum, please Login or Join Today!

   

Slideshow Images Not Showing

{name}
Rank

Total Posts: 3

Joined 2012-02-22

PM

 

My images on the displayed Slideshow are not showing any longer http://www.eastwestmartialarts.org  I’ve had a similar issue but this time all permissions seem correct i.e. themes/element/cache set at 777 (currently set at 755) yet the images still aren’t displaying in the slideshow.

If it helps I updated the theme to the latest version 2.4.5. the child is still running at 1.9.8. but as I understand the important thing is that the parent framework is up to date… Has the latest upgrade possibly broke the slideshow?

This must be a permission issue of some form, I did briefly install a security plugin (Better WP Security 3.4.8) before deleting it as it didn’t fully meet my requirements, did this leave files with wrong permissions after deactivating and deleting?

I was also running low on RAM with the VPS this has now been increased so it looks as though this was not the issue.

This all happened at the same time so not sure what is causing the problem…

Thanks in advance.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

This looks like either a problem with the server setup or the WP configuration.

The script is attempting to fetch the image from a different domain:
http://www.eastwestmartialarts.org/wp-content/themes/element/thumb.php?src=http://i2.wp.com/www.eastwestmartialarts.org/wp-content/uploads/2012/08/Little-Dragons-Stretching-12.jpg?resize=950,350&h=350&w=950

You’ll probably need to add these domains to the allowed sites array:
http://i2.wp.com
http://www.eastwestmartialarts.org

Feel free to PM me your wp-admin information and I can probably be of more specific help.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

PM received, thanks. I do believe this is due to the allowed sites security feature of thumb.php. I have pushed out an update to the theme which I believe will resolve this. Can you login to your WordPress admin and update the theme and let me know if this does the trick?

{name}
Rank

Total Posts: 3

Joined 2012-02-22

PM

 

Hello Casey

Thanks for your fast response but unfortunately the update to the theme hasn’t corrected the issue.

http://i2.wp.com is a part of the Wordpress Jetpack plugin, I assume it is a part of the Photon Module, their CDN service. Whether I deactivate this module or not the slideshows don’t work any longer, even after the theme update…

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

Actually, it looks like it is working now, but your /cache directory is not writeable.
http://www.eastwestmartialarts.org/wp-content/themes/element/cache/

{name}
Rank

Total Posts: 3

Joined 2012-02-22

PM

 

It was set on 755, I set it to 777 and all is working! grin Thanks for your help Casey, very much appreciated.