Welcome! To use this support forum, please Login or Join Today!

   

Catchable fatal error: Object of class WP_Error could not be converted to string

{name}
RankRankRankRank

Total Posts: 116

Joined 2011-06-10

PM

 

I am getting this error message when trying to view the images in the gallery I created.  I deleted and added the gallery a couple of times but keep getting same message.

Here is the message:

Catchable fatal error: Object of class WP_Error could not be converted to string in /home/content/h/a/l/haley/html/realty/wp-content/themes/synapse/lib/content_functions.php on line 261

It doesn’t seem that my lightbox is working properly.

http://stellarrealty.com/floor-plans/

Thanks for the help.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

Hi, I was able to reproduce this error, but only when permalinks were not configured. So, setting up your permalink structure may take care of the error (and help your SEO, too).

Another option would be to link to the media file instead of the attachment page and turn on lightbox in the theme settings. Just a few suggestions. Nevertheless, I’ve pushed up an update to address this issue. in v.2.9.2.

{name}
RankRankRankRank

Total Posts: 116

Joined 2011-06-10

PM

 

I am not sure how to set up Permalink Stucture.  Is there a tutorial?

I went to my picture gallery and all the images say that they are linked to “Media File”

{name}
RankRankRankRank

Total Posts: 116

Joined 2011-06-10

PM

 

I also checked my Theme options and I do have the Light Box setup.  I have the check box checked.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

I had the same issue at first. It said “Media File” but after looking at the shortcode, it clearly read link=“post” instead of link=“file”. The gallery was created pre-3.5 so maybe that was the bug/issue because it switches just fine now.

If you switch to the text editor, make sure your [gallery] shortcode is updated with link=“file”. Save and update the page/post and see if that makes it work.

To change your permalink/URL structure, just go to Settings → Permalinks.
http://codex.wordpress.org/Using_Permalinks

{name}
RankRankRankRank

Total Posts: 116

Joined 2011-06-10

PM

 

This is what my text editor say about the gallery.

[gallery columns=“4” ids=“228,53,52,51,50,49,48,47”]

{name}
RankRankRankRank

Total Posts: 116

Joined 2011-06-10

PM

 

Sorry to be a pest, but I have tried everything (I think)

The update that you pushed up will not update for me.  I have tried but it keeps telling me that there is an available update.  Is this for the child theme?

My picture gallery settings are [gallery columns=“4” ids=“228,53,52,51,50,49,48,47”] and I don’t see where I should make sure it says link=“file”

My lightbox is enabled, but not working.

Did you see my message regarding the IDX issue I am having?

THIS ALL UNDER http://WWW.STELLARREALTY.COM

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

I just found an email in my spam folder with the WordPress user you created for me.

The shortcode should be the following. I have updated your page to reflect this.

[gallery columns="4" link="file" ids="228,53,52,51,50,49,48,47"]

Once I added that, I was able to update it using the UI. I think this is a WordPress bug because I was also able to reproduce it in the default (twentytwelve) theme. The updated media manager is fairly new, so I guess that can be expected.

What is the IDX issue?

 

{name}
RankRankRankRank

Total Posts: 116

Joined 2011-06-10

PM

 

Thank for the gallery fix.

My IDX situation is that some of the pages come from IHOMEFINDER via a special link.  Which is found in the admin panel under Optima Expres>>IDX Pages.  I have these pages on my main menu under SEARCH MLS & COMMUNITY SEARCH.  When going to the ones that use the special url, the widgets on the right side will not show.  Last time you went in and worked some magic.  I noticed that the difference between my old domain and this new one is that in the main EDITOR there is no Landing Page - Freeform or Content Page Template, on the new domain.  Not sure if this is what you added, but just something that I noticed.  Sorry for the rambling.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

I believe I recall creating some custom templates for those pages.
Do you still have access to those modified/added template files from the old domain?

{name}
RankRankRankRank

Total Posts: 116

Joined 2011-06-10

PM

 

I just sent you the login for http://www.mystellarhome.com  let me know if that’snot what you need.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

I haven’t received an Email/PM.

{name}
RankRankRankRank

Total Posts: 116

Joined 2011-06-10

PM

 

just pm you. 

sorry, sent it from admin panel in mystellarhome

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

Your new domain doesn’t have the same customizations. I’d start there to eliminate any variables.

Try downloading your old child theme from the mystellarhome.com and overwrite the one on stellarrealty.com. Mainly the landing-page.php file. Be sure to upload it to the child theme directory so it doesn’t get overwritten on the next update.

{name}
RankRankRankRank

Total Posts: 116

Joined 2011-06-10

PM

 

Do I do that from within the admin panel or do I have to go to the hosting account?

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

You can’t create files from the admin panel or I’d have done it for you smile

You’ll need to do it via FTP.