Welcome! To use this support forum, please Login or Join Today!

You are here → Home :: Forum Home :: General WordPress :: Plugins Discussion :: Thread

   

Simplethemes Integrated Slider: Any Plans to Add “Rotate Featured Posts” Function?

{name}
Rank

Total Posts: 16

Joined 2011-05-09

PM

 
Is there any chance that you will be adapting your slider that comes integrated with your themes so that it can rotate recent posts from a category in a "featured content" type of setup.

I have tried the following WP featured content sliders with the latest versions of the Presstige and Onyx themes and they all do not work correctly. When I try them using the WP default TwentyTen theme, they work fine. Site is running WP 3.1.4.

UnPointZero Slider
WP Featured Content Slider
Featured Articles Lite
Smooth Slider
Recent Posts Slider

The problems vary based upon the specific plugin. Some of them are: thumbnails don't show, or size or position correctly, main image doesn't size correctly, titles don't show or format correctly, etc.

I'm guessing there is a php or css code conflict somewhere. It's just strange that they all don't work in one way or another.

Thanks much.
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
I had a similar request for Onyx awhile back.
http://www.simplethemes.com/forum/viewtopic.php?f=26&t=720#p2818 (archived)

I've done the same for Presstige (v.1.4) if you'd like to download the latest version.
(wp-content/themes/presstige/lib/functions/content_functions.php)

Shortcode:
[contentslides effect="slide" thumbsize="200,150" display="image" type="category" ids="5" width="600" height="320" autoplay="3000" speed="700" paginati prevnext="false"


Parameters:
effect: slide,fade,crossfade
display: content, image
(content will display text before the <!--more--> tag. image will display full sized featured images)
thumbsize: width,height of featured image (if set) when used in content display mode.
type: category, pages (display a Post category series of Pages)
ids: comma separated Category/Page ID's (e.g; 1,7,9,12)
width: Slider Width
height: Slider Height
autoplay: time in milliseconds to auto advance to next slide
speed: duration of slide/fade animation
pagination:true,false (shows bullet pagination)
prevnext: true,false (shows previous and next arrows)


In regards to other sliders, please see this post:
http://www.simplethemes.com/support/viewthread/74/#242


{name}
Rank

Total Posts: 16

Joined 2011-05-09

PM

 
Casey,

Thanks for adding the content functionality to the Presstige theme slider. I downloaded and installed Presstige 1.4 and tested the shortcode you provided.

There is a problem.

When I insert the short code and set the "display" parameter to "image" the slider works correctly (rendering the featured image for the category posts in the slide window). However, when the display parameter is set to "content", the following error occurs:

"Fatal error: Call to undefined function get_formatted() in the /root path redacted for security purposes/presstige/lib/functions/content_functions.php file on line 848."

In checking line 848 of the content_functions.php file, it looks like this section of code is calling the "read more" button to be placed in the slide. In line 847 the display parameter is set to "image". When I changed the display parameter to "content" the error disappears and the slide renders the post image thumbnail and the post title, but NOT the content prior to the "read more" break and NOT the "read more" button.

As I am not a coder, I have reached the extent of my trouble-shooting capabilities.

Any help you could provide will be appreciated.

On another note, I may have found a bug in the default slider configuration, but not sure, so I will post that separately so as not to mix up issues.

Thanks.
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
Ah yes, I left out one function. I'll push this out tonight with the rest of the updates.

lib/content-functions.php:

just before this line:

// SLIDESHOW POST TYPE


Add:

function get_formatted ($more_link_text = '(more...)', $stripteaser = 0, $more_file = '') {
 $content = get_the_content($more_link_text, $stripteaser, $more_file);
 $content = apply_filters('the_content', $content);
 $content = str_replace(']]>', ']]&gt;', $content);
 return $content;
}
{name}
Rank

Total Posts: 16

Joined 2011-05-09

PM

 
Thanks for the response and the posted code.

I inserted the code as instructed in your post and there was not change in the way the slides display. Still NO content text before the "read more" break and NO "Read More" button.

I cleared the browser cache and I'm not running a cache plugin on this site (it's a test site). I inserted the code you gave me two times - i.e., took the original file that was saved on my desktop and inserted the code and reuploaded the file twice. I also checked to make sure that the changed php file was successfully uploaded via FTP to my site.

Still no change - problem still there.
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
Did you change the display parameter in your shortcode to 'content'?
e.g; [contentslides display="content"...

I am able to reproduce the 'Read more' link not showing, but I am able to see the title, post thumbnail, and content.

With 'content' slides, it is not possible to split the_content at the <!--more--> tag at this point. Instead I've included the title, excerpt, and custom thumbnail.

This update is live for Presstige, Onyx, Impacto, and Breeze.
{name}
Rank

Total Posts: 16

Joined 2011-05-09

PM

 
Thanks Casey,

When I installed the new Presstige theme this morning that you pushed through last night, everything works correctly for the "content" slider.

Thanks a ton.