Welcome! To use this support forum, please Login or Join Today!

   

Footer Parallax Issue (Hidden Behind Content)

{name}
Rank

Total Posts: 3

Joined 2014-07-19

PM

 

I’ve noticed inconsistencies with the footer parallax behavior. See this page for example:
http://conchrepublicmusic.com/schedule/

I’m on Chrome on a Mac and the footer is not visible (hidden behind the content above it). Other pages deliver the footer in different places, some visible, some only partially visible.

I have made some customizations to the CSS but even after disabling all of the customizations the problem still exists.

Please advise.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

Hi, You can change the footer parallax height within your child theme. You should see a documented/commented function inside lightfast-child/functions.php:

function child_footer_height() {
 
return 355;
}
add_filter
'skeleton_footer_height''child_footer_height'); 

In your case, since you’re not loading widgets, you can reduce this by changing 355 to something like 120.

{name}
Rank

Total Posts: 3

Joined 2014-07-19

PM

 

Ah that makes sense. Thank you for the reply.

{name}
Rank

Total Posts: 7

Joined 2014-09-25

PM

 

I’m having the same problem, and no matter what I change the 355 to the text remains unseen. Right now I only have the menu and simple theme copyright on the footer. Once, when I refreshed the screen, the text flashed onto the footer for just a second and then was gone. Any ideas?

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

@milany Can you provide a link to what you have?

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

PM received, thanks. You may want to change 350 to something like 100 since your footer is shorter than 350.

If that doesn’t take care of it, can you let me know what browser are you experiencing this in? Also, does this only happen when you’re logged in to wp-admin?

{name}
Rank

Total Posts: 7

Joined 2014-09-25

PM

 

Thanks Casey. I turned maintenance mode back on for now. After receving your replay I checked the site in Internet Explorer and could see nothing, then Chrome and could see nothing, the in my browser of preference, Firefox, and could see nothing. The I went back to Chrome and refreshed the screen and it appeared. I turned wp-admin off and still couldn’t see it in Firefox. Yesterday, I changed the number even to 20 and no luck. I have Windows 8, would that make a difference? Thanks so much for your help.

{name}
Rank

Total Posts: 7

Joined 2014-09-25

PM

 

back to the footer: now when I refresh the screen, the text seems to appear and appear for a second as if it were coming up from the bottom of the screen, and quickly disappears. It doesn’t seem to make a difference whether the number is set to 350 or 120, same thing happens.

{name}
Rank

Total Posts: 7

Joined 2014-09-25

PM

 

Last post for awhile. I started working on internal pages and there doesn’t seem to be a problem there; only on the home page. I’m going to put the rest of the site together and then we’ll see what is going on. Thanks again for your help.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

I’ll be glad to look into it further. I’ll test locally to see if I can replicate what you have or if you’re comfortable PMing me with a temporary wp-admin login, that would be fine, too.

{name}
Rank

Total Posts: 1

Joined 2014-10-04

PM

 

I appear to be having the same problem where the foot is visible while the page loads and then disappears leaving just the grey box with not content. Can you advise of a way to disable the parallax scrolling in the footer.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

Have you tried changing the value to 0 (to disable)?

{name}
Rank

Total Posts: 3

Joined 2015-07-21

PM

 

Casey - I’m having the same trouble on my website: http://www.tempochange.com. Tried setting the value to 0, and it doesnt seem to change anything. Help appreciated! Thanks.

{name}
Rank

Total Posts: 3

Joined 2015-07-21

PM

 

Casey - nevermind, just figured out that the whole functions.php file was commented out. Faceplant.