Welcome! To use this support forum, please Login or Join Today!

   

Shortcode Note in Column with Image

{name}
RankRankRank

Total Posts: 52

Joined 2014-11-03

PM

 
Hi Casey,

Could you please advise how we could mix a note or alert etc. and an image in the same column? The note runs over the text column. I tried putting a DIV around the note but couldn't find the right CSS for making it work.
[note style="info" show_icon="true"]Illinois has municipal elections in February and April of odd years.[/note]

http://votec.eplatt.com/products/cookcounty




Thanks!


Attachments:

https://www.filepicker.io/api/file/ayk074hFSxSvYbXfEPsB
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
The note classes are a block level element so you'll need to put your image in a [one_fourth] shortcode and the content to the right in a [three_fourth_last] shortcode.

[one_fourth]
<img class="aligncenter"/>
[/one_fourth]
[three_fourth_last]
content
...
[/three_fourth_last]
Biggest lessons learned were
.... 
{name}
RankRankRank

Total Posts: 52

Joined 2014-11-03

PM

 
That's a way to do it.
Though oddly, the first paragraph loses the text size I gave all paragraphs (body p {font-ize: 16px;} ) because for some reason WordPress doesn't consider it a paragraph.
So I put paragraph tags around it.
But now it's back to 16px with my

tags gone. Weird.


Thanks again.

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
Try giving your <p> tag a class name definition. For some reason if you just add <p> it will strip it out. <p class="p"> however, will stick...

Not sure if this is related to your problem, but above you have:

body p {font-ize16px;


which might need to be:

body p {font-size16px;
{name}
RankRankRank

Total Posts: 52

Joined 2014-11-03

PM

 
Doesn't look lik ei need the paragraphs anymore. Like I said for some reason the lost 16px settings corrected itself.
(That was just a typo in my posting about "body p {font-ize: 16px;} " – style sheet is OK).

Another irritation is that there was a large gap after the three-quarter columns, so I had to add:

to the next paragarph.