Welcome! To use this support forum, please Login or Join Today!

You are here → Home :: Forum Home :: General WordPress :: WordPress :: Thread

   

Thumbs in latest posts not showing

{name}
Rank

Total Posts: 3

Joined 2015-03-18

PM

 
Hi,

My latest posts are failing to display thumbs and I'm not sure why, despite having gone through several troubleshooting pages. Permissions for the cache folder are set to 777.

My page is currently on a temporary url: http://176.32.230.7/transitionheathrow.com/. You can see the error appearing on the home page.

I would really appreciate any help.

Thanks
Jack
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
Hi Jack,

Apologies for the delayed reply.

I see what you mean. The thumbnail image is definitely there:
http://176.32.230.7/transitionheathrow.com/wp-content/uploads/2015/03/5th-Birthday-19.jpg 


but the thumbnail generator is giving this error.

I think this may have something to do with your server configuration or possibly a symlink. Try specifying the actual document root and add the following to wp-content/themes/mobius/thumb.php.

define('LOCAL_FILE_BASE_DIRECTORY'"/home/www/mysite/"); 


(obviously replacing /home/www/mysite/ with your server path settings)


If this is something you're unable to identify or if I've totally confused you, please feel free to PM or email your wp-admin and/or FTP information and I'll be glad to look into it further for you.
{name}
Rank

Total Posts: 3

Joined 2015-03-18

PM

 
Thanks Casey, I've just PM'd you.
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
Thanks for your patience. This should be working now.

The problem is the directory "transitionheathrow.com" doesn't actually exist.

The solution is actually to fallback to the WP core thumbnail generator. For the longest time we've used timthumb.php to generate thumbnail images, but the developer has recently announced end of life for the script and thankfully WordPress gives us more control over image resizing.

You should be good to go for now, but I'll be pushing out an update to address this in an upcoming release.
{name}
Rank

Total Posts: 3

Joined 2015-03-18

PM

 
It is! That's brilliant. Thanks Casey.

Yes I understand timthumb causes a lot of problems, so that's refreshing to hear.

Best wishes.
{name}
Rank

Total Posts: 3

Joined 2015-03-18

PM

 
Hi Casey

Please could you resolve the same issue with slideshows? The timthumb error occurs with these, as demonstrated here:
http://176.32.230.7/transitionheathrow.com/grow-heathrow-celebrates-its-5th-birthday-in-style/

Cheers
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
Hi, Would you mind installing the following plugin and let me know if the slideshow functionality works as expected?
https://wordpress.org/plugins/otf-regenerate-thumbnails/

Using the previously provided information, I updated your Mobius theme with the latest snapshot. The slideshow thumbnail generation is stable, but still under development.