Welcome! To use this support forum, please Login or Join Today!

You are here → Home :: Forum Home :: General WordPress :: Plugins Discussion :: Thread

   

Modern Tribe Events with Simple Themes Breeze

{name}
Rank

Total Posts: 2

Joined 2014-10-16

PM

 
I have been running the Breeze Theme from Simple Themes in addition to using Events Calendar from Modern Tribe. An example event is:
http://www.goldensrule2015.org/event/hunt-test/
There should be a feature image between the date and the body, which begins "While the GRCA National...". This feature image is in the "tribe-events-event-image" div container.

This is in the page at:
<div class="tribe-events-event-image">
     <
img width="1000" height="299" src="http://www.goldensrule2015.org/wp-content/uploads/2014/10/HT_choo.jpg" class="attachment-full wp-post-image" alt="HT_choo" scale="0">
</
div

However, for some reason, the container which is 960 pixels wide is 0 pixels high, which means it doesn't show. When I switch to the the stock TwentyFourteen theme, this header image seems to work fine. It therefore seems to be a conflict with Breeze (I recently upgraded both Breeze and Event Calendar, which was stupid, in hindsight).

I tried to reinforce the ccs for the tribe-events-event-image container in style5.css, without luck, although I copy it here for thoroughness:
/* Tribe Event Image */
.tribe-events-event-image {
    margin
0 0 20px 0;
    
text-aligncenter
}

.tribe-events-event-image img {
    max
-width100%;
    
heightauto
}
.tribe-events-list .tribe-events-event-image {
    float
left;
    
width30%;
    
margin0 30 0
}

.tribe-events-list .tribe-events-event-image img {
    width
100%;
    
heightauto;
    
margin0;
    
padding0
}

.tribe-events-list .tribe-events-event-image+div.tribe-events-content {
    float
left;
    
width67%;
    
positionrelative
}
.single-tribe_events .tribe-events-event-image {
    clear
both;
    
text-aligncenter;
    
margin-bottom30px


Any thoughts? Thanks for any insight you can provide.
Sincerely,
Robert
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
Hi Robert,

It looks like you have some custom CSS being called from here:
http://www.goldensrule2015.org/?custom-css

The offending rule is:

img.wp-post-image{display:none !important} 


The above rule hides the tribe events image and the WordPress post image.

You could add the following rule after it to implicitly show the tribe events image:

.tribe-events-event-image img.wp-post-image{display:inline !important;


*FYI, display:none does not prevent the image from loading. For better performance, you might want to add a function that tells WP/Tribe not render it at all.

I'm not sure what the purpose of this rule is, but I'm pretty sure tribe events has several conditional hooks to achieve this.
{name}
Rank

Total Posts: 2

Joined 2014-10-16

PM

 
@Casey,
As usual, this worked like a champ! And thanks for the tribe link. I'll look into it to figure if there is a more kosher way to show these images.
Thank you!
Robert