Welcome! To use this support forum, please Login or Join Today!

   

Teaser image problem

{name}
Rank

Total Posts: 1

Joined 2015-08-27

PM

 

I just purchased the “lightfast” theme and I tried to do some very basic things such as adding a logo to the header and then changing the background image of the “teaser”.  The teaser never shows up and I can see that inside of custom.js that the element #teaser does not exist when the page is loaded and this seems to be the issue.

if (enabled == 1 && !mobile) {
  $(’#header’).fixTo(’#teaser’,{
  className : ‘sticky’,
  zIndex: 99
  });
};

Note that I *can* see and change the background within the admin panel (no JS error), the error and problem only occurs when viewing the site directly.

Can someone please get back to me ASAP.  This is for an important client of mine and not sure what to do at this point.

Dave

PS Using on localhost setup with WordPress Version : 4.3 (using ampps)

{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 

Hi,

Is your front/home page set to “Your Latest Posts” or “Static Page” under Settings → Reading?
Are all the teaser options populated?

There are three methods to display a teaser:

1.) By creating a Page with the Page Template set to “Teaser Page”
2.) By creating a Page with the Page Template set to “Layout Builder”
3.) Or if your home page is your blog, then via the “Customize” menu

http://cl.ly/image/3F3G1v141Y12

The “enabled” option in custom.js is purely for the parallax functionality and is set by the system in any of the above scenarios.

{name}
Rank

Total Posts: 1

Joined 2015-08-27

PM

 

Thanks for the response.

To simplify the problem description, I can see that actually if you simply install the theme, make ZERO modifications, and then view the home page you will not see the teaser image even though it is setup to display.  There is a JS error in the console as shown above.  This is with a clean setup using latest version of WP on my local.

That said, using the info in your post above, I was able to create a new page and then set the front page to point to that and the JS error goes away and I can see the image, change it, etc..  Thanks for that.

So, I am good for now, but of course it would be good for someone to look into fixing the theme to not have JS errors after initial installation.

Thanks,
Dave

{name}
Rank

Total Posts: 14

Joined 2015-03-27

PM

 

Hi Casey,

I would like to set up and use a teaser page (assuming I understand this correctly to be the location directly to the right of the logo) with social media contact information but when trying to follow you instructions above I don’t actually see “Teaser Page” as a page template option for a new page?  I am very new to WP so probably missing something obvious.  I am also not sure what you mean in the comment “are all the teaser options populated” - I can’t see any options?

Can you offer any further help to get me started please?

Regards
Barrie