Welcome! To use this support forum, please Login or Join Today!

   

SSL/TLS Errors in Synapse 3.1.7 & Smpl-shortcodes plugin - Please help

{name}
RankRank

Total Posts: 47

Joined 2012-08-10

PM

 

Hello,


I’m using Synapse 3.1.7 on the latest Wordpress and I run several sites with 100% SSL/TLS.  Unfortunately, I’m seeing some links generated by the theme that are http only.  This causes an error on the site for Firefox and other browsers as it list the site as having “insecure” content.  My entire site is SSL/TLS and it is set globally in General settings.  Is there a plan to fix this in future versions?  It would be even better if we could specify this (http or https as default) in the theme as a whole.

A few examples are:

http://www.example.com.com/wp-content/themes/synapse-child/images/apple-touch-icon-114x114.png
http://www.example.com.com/wp-content/themes/synapse-child/images/apple-touch-icon-72x72.png
http://www.example.com.com/wp-content/themes/synapse-child/images/apple-touch-icon.png
http://www.example.com.com/wp-content/themes/synapse-child/images/favicon.ico
http://www.example.com.com/wp-content/themes/synapse-child/images/style1/arrow_bullet.png
http://www.example.com.com/wp-content/themes/synapse-child/images/style3/nav_bg_bdr.png
http://www.example.com.com/wp-content/themes/synapse-child/images/style3/nav_bg_hover.png
http://www.example.com.com/wp-content/themes/synapse-child/images/style3/nav_bg.png

AND the
http://www.example.com.com/wp-content/plugins/smpl-shortcodes/assets/images/underlay.png


Thanks,
Joe

{name}
RankRank

Total Posts: 47

Joined 2012-08-10

PM

 

I’m seeing this code in the parent Synape theme in header.php

<!—Favicons
==================================================—>

<link rel=“shortcut icon” href=”<?php echo get_stylesheet_directory_uri();?>/images/favicon.ico”>

<link rel=“apple-touch-icon” href=”<?php echo get_stylesheet_directory_uri();?>/images/apple-touch-icon.png”>

<link rel=“apple-touch-icon” sizes=“72x72” href=”<?php echo get_stylesheet_directory_uri();?>/images/apple-touch-icon-72x72.png” />

<link rel=“apple-touch-icon” sizes=“114x114” href=”<?php echo get_stylesheet_directory_uri();?>/images/apple-touch-icon-114x114.png” />

<link rel=“pingback” href=”<?php echo get_option(‘siteurl’) .’/xmlrpc.php’;?>” />

<?php if (of_get_option(‘dev_mode’) == ‘1’) { ?>
<link rel=“stylesheet” id=“custom” href=”<?php echo home_url() .’/?get_styles=css&sidebar=’.sidebar_position();?>” type=“text/css” media=“all” />
<?php }

Looks like it is producing http links.  How do I fix this?

{name}
RankRank

Total Posts: 47

Joined 2012-08-10

PM

 

I fixed all the errors one by one by debugging and reviewing the code.  Looks like it works fine now.