Welcome! To use this support forum, please Login or Join Today!

   

Blog Missing Sidebar

{name}
Rank

Total Posts: 11

Joined 2015-09-04

PM

 
My sidebar shows on posts but not on the general blog page, http://www.water-law.com/blog Any ideas why not?
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
Hi Scott,

Is it possible you have the sidebar disabled under:
Appearance → Theme Options → Blog Options
Hide the sidebar on blog home (useful for some layout styles)?
{name}
Rank

Total Posts: 11

Joined 2015-09-04

PM

 
I wish. I tried checking it and unchecking it. Doesn't make any difference on my blog. Thanks for the speedy reply!
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
Very strange. The sidebar shows up fine on subsequent pages: http://www.water-law.com/blog/page/2/

I'm unable to reproduce this locally.
Any chance you could PM me with a temporary wp-admin and/or possibly FTP?
{name}
Rank

Total Posts: 11

Joined 2015-09-04

PM

 
Done. Let me know... Many thanks. I'll take it down tonight unless you need it longer.
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
Found the bug: sidebar.php needs to be replaced.

I pushed up an update to 5.6.7.
We just migrated our server last night, so hopefully everything goes smoothly with the upgrade process. Please let me know if not.

Here is the new sidebar.php:
http://cl.ly/3s2j0M0E1z24
http://cl.ly/3e4614443t0M


Thanks for your patience.
{name}
Rank

Total Posts: 11

Joined 2015-09-04

PM

 
I think you mean i should update theme and that will cover it? Or install the new sidebar.php separately? Thanks.
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
What I meant is you can apply the update manually if the update server is not online at the moment smile
Either way is the same effect.
{name}
Rank

Total Posts: 11

Joined 2015-09-04

PM

 
Blog works the same :-( . Update had an error finish; i uploaded the new sidebar.php, but at the same time i noticed the rest of the files had updated as well.
{name}
RankRankRankRank

Total Posts: 3667

Joined 2011-04-27

PM

 
As it turns out, it was falling back to the default wide page in theme options. I updated the file for some more sane defaults which will be automatically applied in the next update. You should be good to go now!
{name}
Rank

Total Posts: 11

Joined 2015-09-04

PM

 
Hah!! Works! I think that it worked originally but something changed along the way, perhaps a Wordpress update. Anyway, many thanks for the help and prompt response!