Welcome! To use this support forum, please Login or Join Today!


Synapse Fatal Error when trying to upgrade to WP 4.7


Total Posts: 8

Joined 2012-12-20



I am getting the following Fatal Error when I try to update to WP 4.7:

Fatal errorCall to a member function add_filter() on a non-object in C:\wamp-2.5\www\nmrborg\wp-includes\plugin.php on line 111
Call Stack
# Time Memory Function Location
1 0.0005 185120 {main}( ) ..\about.php:0
2 0.0009 228712 
require_once( 'C:\wamp-2.5\www\nmrborg\wp-admin\admin.php' ) ..\about.php:10
3 0.0013 241464 
require_once( 'C:\wamp-2.5\www\nmrborg\wp-load.php' ) ..\admin.php:31
4 0.0015 249256 
require_once( 'C:\wamp-2.5\www\nmrborg\wp-config.php' ) ..\wp-load.php:37
5 0.0020 346864 
require_once( 'C:\wamp-2.5\www\nmrborg\wp-settings.php' ) ..\wp-config.php:107
6 0.2116 19452048 do_action
( ) ..\wp-settings.php:449
7 0.2116 19452464 WP_Hook
->do_action( ) ..\plugin.php:453
8 0.2116 19452512 WP_Hook
->apply_filters( ) ..\class-wp-hook.php:323
9 0.2774 20481120 call_user_func_array
:{C:\wamp-2.5\www\nmrborg\wp-includes\class-wp-hook.php:298} ( ) ..\class-wp-hook.php:298
10 0.2774 20481392 wprc_filter_uber_alles
( ) ..\class-wp-hook.php:298
11 0.2775 20486376 add_filter
( ) ..\wp-installer.php:245 

I tried on the live site at nmrb.org and had to restore from backup. Then tried on my wamp server and got this same exact error.

I have updated 12 other websites using other themes with no problems on the same live server so thought maybe it is related to the Synapse theme?

Any help, or suggestions please…



Total Posts: 6

Joined 2017-01-13



Hello, I’m sorry to learn you’re having problems.
The site owner (Casey) is unhealthy and has hired me to participate in resolving outstanding issues while he is away.

Are all of the other sites you’ve successfully updated using the same plugins? The error message indicates something is either corrupt in the WordPress core filesystem or there is a plugin that is causing conflict.

You may try replacing your core files with a fresh installation of WordPress *except for the wp-config.php and wp-content directory - backup first. If you still get errors, then it’s probably either the plugin, child theme, or theme (in that order).

** I tried replicating this problem by installing WordPress 4.0, Installing/Activating Synapse, Updating to WordPress 4.7. Did not receive error.